package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\+\d{3}-\d{3}-\d{6}$`)
var str = `+251-911-123456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}