package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\$\$.*?)lo(.*?\$\$)`)
var str = `some random text $$ hello world $$ some more stuff`
var substitution = "\15\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}