// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\$\$.*?)lo(.*?\$\$)").unwrap();
let string = "some random text $$ hello world $$ some more stuff";
let substitution = "\\15\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}