import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https:\\/\\/(t|tlgrm|telegram)\\.me\\/|tg:\\/\\/)proxy\\?server=.+&port=[0-9]{0,5}&secret=[a-z0-9]{32}";
final String string = "tg://proxy?server=198.143.181.185&port=80&secret=b378518a9d340be274076e73c994d4cb";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}