const regex = /(https:\/\/(t|tlgrm|telegram)\.me\/|tg:\/\/)proxy\?server=.+&port=[0-9]{0,5}&secret=[a-z0-9]{32}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https:\\\/\\\/(t|tlgrm|telegram)\\.me\\\/|tg:\\\/\\\/)proxy\\?server=.+&port=[0-9]{0,5}&secret=[a-z0-9]{32}', 'g')
const str = `tg://proxy?server=198.143.181.185&port=80&secret=b378518a9d340be274076e73c994d4cb`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
    // This is necessary to avoid infinite loops with zero-width matches
    if (m.index === regex.lastIndex) {
        regex.lastIndex++;
    }
    
    // The result can be accessed through the `m`-variable.
    m.forEach((match, groupIndex) => {
        console.log(`Found match, group ${groupIndex}: ${match}`);
    });
}