#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=^0{0,100}[^\W0]\w{3,100})\w(?=\w{4,}$)"
Local $sString = "0001113033AA55608981" & @CRLF & _
"23456237472347823923" & @CRLF & _
"00000000090000000000" & @CRLF & _
"09008000800060050000" & @CRLF & _
"AAAABBBBCCCCDDDDEEEE" & @CRLF & _
"0000BBBBCCCCDDDDEEEE"
Local $sSubst = "*"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)