#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)g\.command (<#\d+>)\nhttps?:\/\/[a-z0-9.-]+\n.+"
Local $sString = "g.command <#123456790>" & @CRLF & _
"https://ex1am1m1ple.com" & @CRLF & _
"name bla bla" & @CRLF & _
"descropsadqwd qw dqw qdw " & @CRLF & _
"asd dqw wq dwq dwdwwd" & @CRLF & _
"wqdqwdqwidqwdjqwd qwdwq doijqoiw djq"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")