#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https?:\/\/[!-~]+?&query=(?=.*[^!-~]).+$"
Local $sString = "https://weixin.sogou.com/weixin?type=2&ie=utf-8&s_from=hotnews&query=나." & @CRLF & _
"https://weixin.sogou.com/weixin?type=2&ie=utf-8&s_from=hotnews&query=Tôi" & @CRLF & _
"https://weixin.sogou.com/weixin?type=2&ie=utf-8&s_from=hotnews&query=测试" & @CRLF & _
"https://weixin.sogou.com/weixin?type=2&ie=utf-8&s_from=hotnews&query=test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")