import Foundation
let pattern = #"^https?:\/\/[!-~]+?&query=(?=.*[^!-~]).+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://weixin.sogou.com/weixin?type=2&ie=utf-8&s_from=hotnews&query=나.
https://weixin.sogou.com/weixin?type=2&ie=utf-8&s_from=hotnews&query=Tôi
https://weixin.sogou.com/weixin?type=2&ie=utf-8&s_from=hotnews&query=测试
https://weixin.sogou.com/weixin?type=2&ie=utf-8&s_from=hotnews&query=test
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)