const regex = /(?<=(index|Point|Frame)=")([^"]+)(?=".*?id="([^"]+)" node="\2")/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=(index|Point|Frame)=")([^"]+)(?=".*?id="([^"]+)" node="\\2")', 'gs')
const str = `<movingPart index="0>8|1|3" referencePoint="0>8|1|0|4" referenceFrame="0>" scaleZ="true"/>
bla
bla
<i3dMapping id="KroneComprimaV180XC" node="0>" />
<i3dMapping id="novoGripPart2_fixPoint" node="0>8|1|0|4" />
<i3dMapping id="novoGrip_part2" node="0>8|1|3" />`;
const subst = `\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);