# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\w*\`\b/`;/gm;t' <<< "Name1 `Value1` Name2 `Value2` `Name3` Value3
"