$re = '/(\w+:\/\/\/)((\w+\/)+)(\w+.\w+)|(\w+\/\w+.\w+)/';
$str = 'client_files/ezsharae.jar
file:///home/aaron/EZShare/ezshare.jar ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);