#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.*\d{5,}.*)|(^(\,|\.|\\|\'|\-|\?|\*|\(|\@|\^|\=|\/|\%|\").*)|(.*(\<|\>|\[|\]|\;).*)|(.*(\.html|\.php).*)|^(\d\.\d)|(^\\.*)|(^\%.*\%)|(\d{1,3}(((x|\.|\.[[:space:]]){1,2})|[[:space:]])\d{1,3})|.*x$|^0[a-z]*|.{50,}"
Local $sString = "<script>alert('hai');</script>" & @CRLF & _
"0.8 " & @CRLF & _
"003902" & @CRLF & _
",eja kerja" & @CRLF & _
".akeup" & @CRLF & _
"081320266690" & @CRLF & _
"1 set meja kursi" & @CRLF & _
"0elan" & @CRLF & _
"meja makan" & @CRLF & _
"100 meja" & @CRLF & _
"12 cm" & @CRLF & _
"10023995" & @CRLF & _
"]" & @CRLF & _
""abcd"" & @CRLF & _
"\yj magnolia" & @CRLF & _
"%m087%" & @CRLF & _
"'t. shower set kris prem rev wht ptss-0211-5w " & @CRLF & _
"-tangga/kamar-mandi/1kvigy-jual-title-deck-karpet-anti-licin-bath-mat-anti-slip" & @CRLF & _
"? sarapan✅ lunch crew✅ snack crew✅ video on process undangan ? roundown ✅ backdrops✅ photo booth✅ documentation ✅ rooms hotel ? catering ? panggung ? opening speech ? flag dance ✅ door prizes? seragam ? cue card ?. d . ," & @CRLF & _
"?meja?" & @CRLF & _
"'merlott mylo set meja makan" & @CRLF & _
"*"tangga"*" & @CRLF & _
"@meja" & @CRLF & _
"(u/6)" & @CRLF & _
"*晶杯子" & @CRLF & _
"/*meja*/" & @CRLF & _
"/%meja" & @CRLF & _
"====" & @CRLF & _
"^meja^" & @CRLF & _
"14 pcs radiator cup tester ( top quality ) alat tes kebocoran radiator " & @CRLF & _
"120x200x35 cm jty202 ubah lokasi produk hanya bisa di ambil di lippo plaza kupang (informa) verified brand linotela dikirim oleh ruparupa detail produk" & @CRLF & _
"640 × 640gambar mungkin memiliki hak cipta. pelajari lebih lanjut kuncibengkel" & @CRLF & _
"%meja" & @CRLF & _
"%mp18.html" & @CRLF & _
"100x" & @CRLF & _
"25x25" & @CRLF & _
"250x250" & @CRLF & _
"123. 456" & @CRLF & _
"123.456" & @CRLF & _
"123 456"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")