package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*\d{5,}.*)|(^(\,|\.|\\|\'|\-|\?|\*|\(|\@|\^|\=|\/|\%|\").*)|(.*(\<|\>|\[|\]|\;).*)|(.*(\.html|\.php).*)|^(\d\.\d)|(^\\.*)|(^\%.*\%)|(\d{1,3}(((x|\.|\.[[:space:]]){1,2})|[[:space:]])\d{1,3})|.*x$|^0[a-z]*|.{50,}`)
var str = `<script>alert('hai');</script>
0.8
003902
,eja kerja
.akeup
081320266690
1 set meja kursi
0elan
meja makan
100 meja
12 cm
10023995
]
"abcd"
\yj magnolia
%m087%
't. shower set kris prem rev wht ptss-0211-5w
-tangga/kamar-mandi/1kvigy-jual-title-deck-karpet-anti-licin-bath-mat-anti-slip
? sarapan✅ lunch crew✅ snack crew✅ video on process undangan ? roundown ✅ backdrops✅ photo booth✅ documentation ✅ rooms hotel ? catering ? panggung ? opening speech ? flag dance ✅ door prizes? seragam ? cue card ?. d . ,
?meja?
'merlott mylo set meja makan
*"tangga"*
@meja
(u/6)
*晶杯子
/*meja*/
/%meja
====
^meja^
14 pcs radiator cup tester ( top quality ) alat tes kebocoran radiator
120x200x35 cm jty202 ubah lokasi produk hanya bisa di ambil di lippo plaza kupang (informa) verified brand linotela dikirim oleh ruparupa detail produk
640 × 640gambar mungkin memiliki hak cipta. pelajari lebih lanjut kuncibengkel
%meja
%mp18.html
100x
25x25
250x250
123. 456
123.456
123 456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}