import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*\\d{5,}.*)|(^(\\,|\\.|\\\\|\\'|\\-|\\?|\\*|\\(|\\@|\\^|\\=|\\/|\\%|\\\").*)|(.*(\\<|\\>|\\[|\\]|\\;).*)|(.*(\\.html|\\.php).*)|^(\\d\\.\\d)|(^\\\\.*)|(^\\%.*\\%)|(\\d{1,3}(((x|\\.|\\.[[:space:]]){1,2})|[[:space:]])\\d{1,3})|.*x$|^0[a-z]*|.{50,}";
final String string = "<script>alert('hai');</script>\n"
+ "0.8 \n"
+ "003902\n"
+ ",eja kerja\n"
+ ".akeup\n"
+ "081320266690\n"
+ "1 set meja kursi\n"
+ "0elan\n"
+ "meja makan\n"
+ "100 meja\n"
+ "12 cm\n"
+ "10023995\n"
+ "]\n"
+ "\"abcd\"\n"
+ "\\yj magnolia\n"
+ "%m087%\n"
+ "'t. shower set kris prem rev wht ptss-0211-5w \n"
+ "-tangga/kamar-mandi/1kvigy-jual-title-deck-karpet-anti-licin-bath-mat-anti-slip\n"
+ "? sarapan✅ lunch crew✅ snack crew✅ video on process undangan ? roundown ✅ backdrops✅ photo booth✅ documentation ✅ rooms hotel ? catering ? panggung ? opening speech ? flag dance ✅ door prizes? seragam ? cue card ?. d . ,\n"
+ "?meja?\n"
+ "'merlott mylo set meja makan\n"
+ "*\"tangga\"*\n"
+ "@meja\n"
+ "(u/6)\n"
+ "*晶杯子\n"
+ "/*meja*/\n"
+ "/%meja\n"
+ "====\n"
+ "^meja^\n"
+ "14 pcs radiator cup tester ( top quality ) alat tes kebocoran radiator \n"
+ "120x200x35 cm jty202 ubah lokasi produk hanya bisa di ambil di lippo plaza kupang (informa) verified brand linotela dikirim oleh ruparupa detail produk\n"
+ "640 × 640gambar mungkin memiliki hak cipta. pelajari lebih lanjut kuncibengkel\n"
+ "%meja\n"
+ "%mp18.html\n"
+ "100x\n"
+ "25x25\n"
+ "250x250\n"
+ "123. 456\n"
+ "123.456\n"
+ "123 456";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}