package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[^\s]+`)
var str = `Appartement 3 pièces de 62 m² à Vitry-sur-Seine (94400)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}