using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @">>(?<name>[A-Za-z]+)<<(?<price>\d+\.?\d+)!(?<quantity>\d+)";
string input = @">>Sofa<<312.23!3
>>TV<<300!5
>Invalid<<!5";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}