re = />>(?<name>[A-Za-z]+)<<(?<price>\d+\.?\d+)!(?<quantity>\d+)/m
str = '>>Sofa<<312.23!3
>>TV<<300!5
>Invalid<<!5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end