$re = '/(?:^|\;)(?=[^"]|(")?)"?((?(1)[^"]*|[^\;"]*))"?(?=\;|$)/m';
$str = '"Code";City;Country/Region Code;County
01067;Dresden;DE;Sachsen
01067;"Dresden Friedrichstadt";DE;Sachsen
01067;Dresden Innere Altstadt;DE;Sachsen
01069;Dresden;DE;Sachsen
01097;Dresden;DE;Sachsen
01099;Dresden;DE;Sachsen
01108;Dresden;DE;Sachsen';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);