import Foundation
let pattern = #"(?:^|\;)(?=[^"]|(")?)"?((?(1)[^"]*|[^\;"]*))"?(?=\;|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"Code";City;Country/Region Code;County
01067;Dresden;DE;Sachsen
01067;"Dresden Friedrichstadt";DE;Sachsen
01067;Dresden Innere Altstadt;DE;Sachsen
01069;Dresden;DE;Sachsen
01097;Dresden;DE;Sachsen
01099;Dresden;DE;Sachsen
01108;Dresden;DE;Sachsen
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)