package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\S*)(\d.\d.\d)\.(0)(\S*)`)
var str = `1.0.0
1.0.0.0
1.1.2.0-tag
1.0.0.1
1.1.2.1-tag
1.0.2-tag
1.0
1.0-tag
1.1-tag
MyPackage.1.0.0
MyPackage.1.0.0.2
MyPackage.1.0.0.0
MyPackage.1.0.0.0.nupkg
MyPackage.1.0.0.4.nupkg
MyPackage.1.0.0.0-mytag
MyPackage.1.0.0.0-mytag.nupkg
MyPackage.1.0.0.1-mytag.nupkg
`
var substitution = "${1}${2}${4}"
fmt.Println(re.ReplaceAllString(str, substitution))
}