const regex = /(\S*)(\d.\d.\d)\.(0)(\S*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\S*)(\\d.\\d.\\d)\\.(0)(\\S*)', 'g')
const str = `1.0.0
1.0.0.0
1.1.2.0-tag
1.0.0.1
1.1.2.1-tag
1.0.2-tag
1.0
1.0-tag
1.1-tag
MyPackage.1.0.0
MyPackage.1.0.0.2
MyPackage.1.0.0.0
MyPackage.1.0.0.0.nupkg
MyPackage.1.0.0.4.nupkg
MyPackage.1.0.0.0-mytag
MyPackage.1.0.0.0-mytag.nupkg
MyPackage.1.0.0.1-mytag.nupkg
`;
const subst = `${1}${2}${4}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);