re = /^(?=\d)(?:\d+w\h*)?(?:\d+d\h*)?(?:\d+h\h*)?(?:\d+m)?$/m
str = '1w 3d 5h 3m
32d 5h 3m
3pp 2h 35m
2d 5qq 3m
2d 35m
3h 1w
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end