# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\S)(?!(?:January|February|March|April|May|June|July|August|September|October|November|December|\d+)(?:\s|$))\S+//g;t' <<< "1 circa February 1950
testing July August Septiembre Octubre 7 8 9 10 10b ... 101"