using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)(?!(?:January|February|March|April|May|June|July|August|September|October|November|December|\d+)(?:\s|$))\S+";
string substitution = @"";
string input = @"1 circa February 1950
testing July August Septiembre Octubre 7 8 9 10 10b ... 101";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}