import re
regex = re.compile(r"(?<!\S)(?!(?:January|February|March|April|May|June|July|August|September|October|November|December|\d+)(?:\s|$))\S+")
test_str = ("1 circa February 1950\n"
" testing July August Septiembre Octubre 7 8 9 10 10b ... 101")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)