import Foundation
let pattern = #"(?<!\S)(?!(?:January|February|March|April|May|June|July|August|September|October|November|December|\d+)(?:\s|$))\S+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1 circa February 1950
testing July August Septiembre Octubre 7 8 9 10 10b ... 101
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)