package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Domicilio:(?<cRegexGroupsName>.*?)Tipo\/Identificador`)
var str = `Dirección Provincial de: BIZKAIAUnidad de Recaudación Ejecutiva nº: 48/08Apellidos y nombre/R.Social: INFRAESTRUCTURAS VAL DIN 2001 S.A.0A95123568 812000059562248NIF/CIF: Nº de referencia: Domicilio: CL BERTENDONA 4 3 DP3 Tipo/Identificador: 10 48105556974 Régimen: 0111 Localidad: 48008 BILBAO Expediente: 48 08 20 00069160 Importe deuda pendiente: 122.779,79 Nº Documento: 48 08 312 20 025162050 DILIGENCIA DE EMBARGO DE CUENTAS CORRIENTES Y DE AHORRO (TVA-312) DESTINATARIO:`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}