use strict;
my $str = 'Dirección Provincial de: BIZKAIAUnidad de Recaudación Ejecutiva nº: 48/08Apellidos y nombre/R.Social: INFRAESTRUCTURAS VAL DIN 2001 S.A.0A95123568 812000059562248NIF/CIF: Nº de referencia: Domicilio: CL BERTENDONA 4 3 DP3 Tipo/Identificador: 10 48105556974 Régimen: 0111 Localidad: 48008 BILBAO Expediente: 48 08 20 00069160 Importe deuda pendiente: 122.779,79 Nº Documento: 48 08 312 20 025162050 DILIGENCIA DE EMBARGO DE CUENTAS CORRIENTES Y DE AHORRO (TVA-312) DESTINATARIO:';
my $regex = qr/Domicilio:(?<cRegexGroupsName>.*?)Tipo\/Identificador/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}