#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([\'\"\`])(.*)\1"
Local $sString = "'string in simple quotes'" & @CRLF & _
""in double-quotes"" & @CRLF & _
"`in back-quotes`" & @CRLF & _
""Works good with symbols ' or " or ` inside the string"" & @CRLF & _
""All quotes "'` inside string are ignored"" & @CRLF & _
""Matches only identical quotes on string start and end' // regex can`t find this" & @CRLF & _
"" & @CRLF & _
""" & @CRLF & _
"Single-line flag allows regex to finde multiline" & @CRLF & _
"strings like this" & @CRLF & _
"" // but now flag s turned of" & @CRLF & _
"" & @CRLF & _
""Group 2 saves text inside quotes""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")