import re
regex = re.compile(r"([\'\"\`])(.*)\1", flags=re.MULTILINE)
test_str = ("'string in simple quotes'\n"
"\"in double-quotes\"\n"
"`in back-quotes`\n"
"\"Works good with symbols ' or \" or ` inside the string\"\n"
"\"All quotes \"'` inside string are ignored\"\n"
"\"Matches only identical quotes on string start and end' // regex can`t find this\n\n"
"\"\n"
"Single-line flag allows regex to finde multiline\n"
"strings like this\n"
"\" // but now flag s turned of\n\n"
"\"Group 2 saves text inside quotes\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")