using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\w+@\w[.\w]+\.\w+\b";
string input = @"user@mail.com
user@sub.main.top
user@abc
user@
@mail.com";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}