package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-zA-Z]{2,4})(_)(\d{2})_(0*)(\d+)(_.+)?`)
var str = `BTS_33_198_D
PL_14_015
`
var substitution = "\1\\\2\3\\_%\5%"
fmt.Println(re.ReplaceAllString(str, substitution))
}