const regex = /^([a-zA-Z]{2,4})(_)(\d{2})_(0*)(\d+)(_.+)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-zA-Z]{2,4})(_)(\\d{2})_(0*)(\\d+)(_.+)?', 'gm')
const str = `BTS_33_198_D
PL_14_015
`;
const subst = `\1\\\2\3\\_%\5%`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);