$re = '/\b[A-Z]+(?:[-\'][A-Z]+)*(?:\/|(?!\S))/m';
$str = 'T-Bar Track T-BAR W/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);