const regex = /^(?:GB\d{2}[A-Z]{4}\d{14}|DE\d{20})|(?!DE|GB)[A-Z]{2}[A-Z\d]{13,}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:GB\\d{2}[A-Z]{4}\\d{14}|DE\\d{20})|(?!DE|GB)[A-Z]{2}[A-Z\\d]{13,}$', 'gm')
const str = `works as expected
DE12312341212312312312
GB12ASDF12312312312311
this should match with fallback
NO1212121212121
BG18RZBB91550123456789
this should not match with fallback:
DE1231234121231
GB1231231231231`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}