using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"10\.\d+\.\d+\.\d$";
string input = @"10.63.69.2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}