use strict;
my $str = '[?]<h1>%empty%</h1>
<p>text</p>
[/?]
text
[?]<h1>%empty%</h1>
<p>text</p>
[/?]
text
[?]<h1>%!empty%</h1>
<p>text</p>
[/?]
text
[?][][/<h1>%empty%</h1>][][[[]]]
<p>text</p>
[/?]
[?]<h1>%empty%</h1>
<p>text</p>[?]
[/?]
text[?]<h1>%!empty%</h1>
<p>text</p>
[/?] ';
my $regex = qr~\[\?\](?:(?!\[/?\?\]).)*%empty%(?:(?!\[\?\]).)*\[/\?]~msp;
my $subst = 'REPLACED';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";