re = /\[\?\](?:(?!\[\/?\?\]).)*%empty%(?:(?!\[\?\]).)*\[\/\?]/m
str = '[?]<h1>%empty%</h1>
<p>text</p>
[/?]
text
[?]<h1>%empty%</h1>
<p>text</p>
[/?]
text
[?]<h1>%!empty%</h1>
<p>text</p>
[/?]
text
[?][][/<h1>%empty%</h1>][][[[]]]
<p>text</p>
[/?]
[?]<h1>%empty%</h1>
<p>text</p>[?]
[/?]
text[?]<h1>%!empty%</h1>
<p>text</p>
[/?] '
subst = 'REPLACED'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result