re = /(\(.*\))?(?:\s(\(thisshouldbegrouptwo\)\s))?(\(.*\))/m
str = '(this) (should) (be) (group) (one) (thisshouldbegrouptwo) (this) (should) (be) (group) (three)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end