#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d{4}([-/.])\d{1,2}\1\d{1,2}"
Local $sString = "i'm using python regex to match dates in forms as: 1999-01-01 or 1999.1.1 or 1999-1-1. but not ones like 1999.1-1 or 1999-1.1.i.e. the signs between year month and day must be consistent. I use the following code to do it which is messy. is there a better way to do it?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")