import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{4}([-/.])\\d{1,2}\\1\\d{1,2}";
final String string = "i'm using python regex to match dates in forms as: 1999-01-01 or 1999.1.1 or 1999-1-1. but not ones like 1999.1-1 or 1999-1.1.i.e. the signs between year month and day must be consistent. I use the following code to do it which is messy. is there a better way to do it?";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}