package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)want.*(\n|.)*grab`)
var str = `I want to
grab as certain
part of the
text that you
see here`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}