re = /want.*(\n|.)*grab/m
str = 'I want to
grab as certain
part of the
text that you
see here'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end