re = /(\d{2}:\d{2}:\d{2})(\d{2}-\d{2}-\d{2})(\w{3}):(\w+?):(\w+?\.\w+?)!.+?,(.+?),(.+?),.*/
str = '00:16:0808-11-20AES:AE022AGES:022.60032S!20FINI/ID60032S,BLUE01,ZPR008A21308/MR1,2/AFLPLA,KPSM/TD071030,10325053
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end