$re = '/^\/$|(\/[a-zA-Z_0-9-]+)+$/m';
$str = '/
/abc
/sab_
/abc/abc/
/sad/dfsd
null
/dsf/dfsdf/dsfsf/sdfds
/e3r/343/8437
/4333/32#
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);