#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((asia|europe|us|australia)|((north|south)(america|africa)))-((east|west|central|north|south)|((north|south)(east)))([0-9]{1,2})"
Local $sString = "(east|west|central|north)?(north|south)?(east)[0-9]{1,2}" & @CRLF & _
"(east|west|central|north)(north|south)(east)[0-9]{1,2}" & @CRLF & _
"" & @CRLF & _
"(north|south)(america)" & @CRLF & _
"" & @CRLF & _
"FireStore Regions" & @CRLF & _
"us-west1 oregon" & @CRLF & _
"us-west2 Los Angeles" & @CRLF & _
"us-west3 Tuz Gölü şehri" & @CRLF & _
"us-west4 Las Vegas" & @CRLF & _
"northamerica-northeast1 Montreal" & @CRLF & _
"northafrica-west3" & @CRLF & _
"southafrica-east1" & @CRLF & _
"us-east1 Güney Carolina" & @CRLF & _
"us-east4 Kuzey Virginia" & @CRLF & _
"southamerica-east1 Sao Paulo" & @CRLF & _
"europe-west2 Londra" & @CRLF & _
"europe-west4" & @CRLF & _
"europe-west3 Frankfurt" & @CRLF & _
"europe-central2 Varşova" & @CRLF & _
"europe-west6 Zürih" & @CRLF & _
"asia-south1 Bombay" & @CRLF & _
"asia-southeast1 Singapur" & @CRLF & _
"asia-southeast2 Cakarta" & @CRLF & _
"asia-east2 Hong Kong" & @CRLF & _
"asia-east1 Tayvan" & @CRLF & _
"asia-northeast1 Tokyo" & @CRLF & _
"asia-northeast2 Osaka" & @CRLF & _
"asia-northeast3 Seul" & @CRLF & _
"australia-southeast1 Sidney" & @CRLF & _
"australia-southeast2" & @CRLF & _
"" & @CRLF & _
"australia-southeast" & @CRLF & _
"" & @CRLF & _
"Function Regions" & @CRLF & _
"" & @CRLF & _
"asia-east1 (Tayvan)" & @CRLF & _
"asia-east2 (Hong Kong)" & @CRLF & _
"asia-northeast1 (Tokyo)" & @CRLF & _
"asia-northeast2 (Osaka)" & @CRLF & _
"europe-west1 (Belçika) " & @CRLF & _
"europe-west2 (Londra)" & @CRLF & _
"us-central1 (Iowa)" & @CRLF & _
"us-east1 (Güney Karolina)" & @CRLF & _
"us-east4 (Kuzey Virginia)" & @CRLF & _
"us-west1 (Oregon)" & @CRLF & _
"asia-northeast3 (Seul)" & @CRLF & _
"asia-southeast1 (Singapur)" & @CRLF & _
"asia-southeast2 (Cakarta)" & @CRLF & _
"asia-south1 (Mumbai)" & @CRLF & _
"australia-southeast1 (Sidney)" & @CRLF & _
"europe-central2 (Varşova)" & @CRLF & _
"europe-west3 (Frankfurt)" & @CRLF & _
"europe-west6 (Zürih) " & @CRLF & _
"northamerica-northeast1 (Montreal) " & @CRLF & _
"southamerica-east1 (Sao Paulo) " & @CRLF & _
"us-west2 (Los Angeles)" & @CRLF & _
"us-west3 (Salt Lake City)" & @CRLF & _
"us-west4 (Las Vegas)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"asia-east1 (Tayvan) us-west2 (Los Angeles) europe-west1 (Belçika)" & @CRLF & _
"us-west3 (Salt Lake City) asia-northeast1 (Tokyo) southamerica-east1 (Sao Paulo)" & @CRLF & _
"us-west4 (Las Vegas) asia-east2 (Hong Kong) northamerica-northeast1 (Montreal)" & @CRLF & _
"europe-west2 (Londra) asia-south1 (Mumbai) europe-west3 (Frankfurt)" & @CRLF & _
"us-central1 (Iowa) europe-central2 (Varşova) europe-west6 (Zürih)" & @CRLF & _
"us-east1 (Güney Karolina)" & @CRLF & _
"asia-northeast3 (Seul)" & @CRLF & _
"us-east4 (Kuzey Virginia)" & @CRLF & _
"australia-southeast1 (Sidney)" & @CRLF & _
"us-west1 (Oregon)" & @CRLF & _
"asia-southeast2 (Cakarta)" & @CRLF & _
"asia-southeast1 (Singapur)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")