const regex = /^(?:[^_\n]+_){3}([0-9A-Za-z]+)(?:_[^_\n]+)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[^_\\n]+_){3}([0-9A-Za-z]+)(?:_[^_\\n]+)*$', 'gm')
const str = `AAA_BBB_CCC_DDD_EEE
This_is_a_test
And_this_is_another_test
This is a test
And_this_is_another_test_again
This_is_a
This_is
This
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}