#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\[[^\]]+\][^\n]+(?:\n[^\[\n][^\n]+)*"
Local $sString = "[08-Jul-2018 08:12:04 UTC] PHP Fatal error: on line 44" & @CRLF & _
"" & @CRLF & _
"[08-Jul-2018 08:22:22 UTC] PHP Fatal error: in ...:37" & @CRLF & _
"Stack trace:" & @CRLF & _
"#0 C:\xampp\htdocs\wordpress\wp-content\themes\news_theme\index.php(37): " & @CRLF & _
"PDOStatement->execute()" & @CRLF & _
"#1 C:\xampp\htdocs\wordpress\wp-includes\template-loader.php(74): " & @CRLF & _
"include('C:\\xampp\\htdocs...')" & @CRLF & _
"thrown in ... on line 37" & @CRLF & _
"" & @CRLF & _
"[08-Jul-2018 08:12:45 UTC] PHP Fatal error: on line 155" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")