import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\[[^\\]]+\\][^\\n]+(?:\\n[^\\[\\n][^\\n]+)*";
final String string = "[08-Jul-2018 08:12:04 UTC] PHP Fatal error: on line 44\n\n"
+ "[08-Jul-2018 08:22:22 UTC] PHP Fatal error: in ...:37\n"
+ "Stack trace:\n"
+ "#0 C:\\xampp\\htdocs\\wordpress\\wp-content\\themes\\news_theme\\index.php(37): \n"
+ "PDOStatement->execute()\n"
+ "#1 C:\\xampp\\htdocs\\wordpress\\wp-includes\\template-loader.php(74): \n"
+ "include('C:\\\\xampp\\\\htdocs...')\n"
+ "thrown in ... on line 37\n\n"
+ "[08-Jul-2018 08:12:45 UTC] PHP Fatal error: on line 155\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}